Intel DCI/DAL/CFL-S halt issue

YouGotIt
Member
Posts: 5
Joined: Thu Apr 26, 2018 1:36 am

Intel DCI/DAL/CFL-S halt issue

Post by YouGotIt » Wed May 09, 2018 4:10 am

I have suffered from the intel system debugger halting the system at very early bios stage(say reset vector) causing system to lose XHCI controller on CFL-S platform.

repro steps:
1. Enable DCI on target system.
2. Connect host and target through dci with intel system debugger.
3. Create reset break bp.
4. Reset target, it will halt at reset vector.
5. Wait for 1 min, then go.
6. It'll stuck at enumerating XHCI controller for very long time.
7. It will finally boot with no XHCI controller enumerated.

Any idea what happened?

User avatar
armstrong
Member
Posts: 23
Joined: Sun Apr 01, 2018 4:34 pm

Re: Intel DCI/DAL/CFL-S halt issue

Post by armstrong » Wed May 09, 2018 2:40 pm

Firstly, make sure you meet the following requirements:
1. The unit under debug must have at least 1 USB 3 port out from Intel silicon.
2. The unit under debug must be configured in "Merge Debug Port Topology" that described in Skylake platform design guide under "platform debug and test hooks" chapter to enable both CPU and PCH debug. Without this topology routed on the board, DCI only has access to PCI which is not sufficient for platform level debug.
3. The unit under debug must enable DCI option in the BIOS setup menu in order for DCI to work properly. The DCI setting is available in BIOS RC.

YouGotIt
Member
Posts: 5
Joined: Thu Apr 26, 2018 1:36 am

Re: Intel DCI/DAL/CFL-S halt issue

Post by YouGotIt » Thu May 10, 2018 6:11 am

Yes, 1, 2, 3 are all there.
Actually, I have used DCI since Skylake.
Skylake, Kabylake won't have this problem.
This only happen on CFL.

matt.huang
Enthusiast
Posts: 30
Joined: Fri Apr 20, 2018 12:06 pm

Re: Intel DCI/DAL/CFL-S halt issue

Post by matt.huang » Thu May 10, 2018 9:17 am

Have you try on Intel SDK (pure CRB), or just vendor-based code?

Looks like you are having multiple issues going on, and both of them are exactly what we've encountered when SKL chipset code at its early stages.

User avatar
BobJC
Member
Posts: 21
Joined: Wed Apr 04, 2018 2:07 pm

Re: Intel DCI/DAL/CFL-S halt issue

Post by BobJC » Thu May 10, 2018 1:58 pm

If I were in you position, I would try the following...
1. Search Intel sighting report for similar issues.
2. Reach Intel FAE or submit IPS ticket for Intel support.

YouGotIt
Member
Posts: 5
Joined: Thu Apr 26, 2018 1:36 am

Re: Intel DCI/DAL/CFL-S halt issue

Post by YouGotIt » Mon May 14, 2018 1:38 am

CFL-S CRB can duplicate the issue.

matt.huang
Enthusiast
Posts: 30
Joined: Fri Apr 20, 2018 12:06 pm

Re: Intel DCI/DAL/CFL-S halt issue

Post by matt.huang » Mon May 14, 2018 12:31 pm

Then I think it might have some issue in current ME firmware, which is affecting both reset vector & XHCI handovers

ChuckD
Member
Posts: 11
Joined: Wed Apr 04, 2018 2:06 pm

Re: Intel DCI/DAL/CFL-S halt issue

Post by ChuckD » Tue May 15, 2018 11:03 am

I used to encounter similar issue and it disappeared when upgrade to a new version of ME.

YouGotIt
Member
Posts: 5
Joined: Thu Apr 26, 2018 1:36 am

Re: Intel DCI/DAL/CFL-S halt issue

Post by YouGotIt » Wed May 16, 2018 3:04 am

Hi ChuckD

Which ME version you use?
I use latest 1087 still duplicate.

ChuckD
Member
Posts: 11
Joined: Wed Apr 04, 2018 2:06 pm

Re: Intel DCI/DAL/CFL-S halt issue

Post by ChuckD » Wed May 16, 2018 10:40 am

That was on Kabylake...

Post Reply