Page 1 of 1

Intel DCI/DAL/CFL-S halt issue

Posted: Wed May 09, 2018 4:10 am
by YouGotIt
I have suffered from the intel system debugger halting the system at very early bios stage(say reset vector) causing system to lose XHCI controller on CFL-S platform.

repro steps:
1. Enable DCI on target system.
2. Connect host and target through dci with intel system debugger.
3. Create reset break bp.
4. Reset target, it will halt at reset vector.
5. Wait for 1 min, then go.
6. It'll stuck at enumerating XHCI controller for very long time.
7. It will finally boot with no XHCI controller enumerated.

Any idea what happened?

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Wed May 09, 2018 2:40 pm
by armstrong
Firstly, make sure you meet the following requirements:
1. The unit under debug must have at least 1 USB 3 port out from Intel silicon.
2. The unit under debug must be configured in "Merge Debug Port Topology" that described in Skylake platform design guide under "platform debug and test hooks" chapter to enable both CPU and PCH debug. Without this topology routed on the board, DCI only has access to PCI which is not sufficient for platform level debug.
3. The unit under debug must enable DCI option in the BIOS setup menu in order for DCI to work properly. The DCI setting is available in BIOS RC.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Thu May 10, 2018 6:11 am
by YouGotIt
Yes, 1, 2, 3 are all there.
Actually, I have used DCI since Skylake.
Skylake, Kabylake won't have this problem.
This only happen on CFL.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Thu May 10, 2018 9:17 am
by matt.huang
Have you try on Intel SDK (pure CRB), or just vendor-based code?

Looks like you are having multiple issues going on, and both of them are exactly what we've encountered when SKL chipset code at its early stages.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Thu May 10, 2018 1:58 pm
by BobJC
If I were in you position, I would try the following...
1. Search Intel sighting report for similar issues.
2. Reach Intel FAE or submit IPS ticket for Intel support.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Mon May 14, 2018 1:38 am
by YouGotIt
CFL-S CRB can duplicate the issue.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Mon May 14, 2018 12:31 pm
by matt.huang
Then I think it might have some issue in current ME firmware, which is affecting both reset vector & XHCI handovers

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Tue May 15, 2018 11:03 am
by ChuckD
I used to encounter similar issue and it disappeared when upgrade to a new version of ME.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Wed May 16, 2018 3:04 am
by YouGotIt
Hi ChuckD

Which ME version you use?
I use latest 1087 still duplicate.

Re: Intel DCI/DAL/CFL-S halt issue

Posted: Wed May 16, 2018 10:40 am
by ChuckD
That was on Kabylake...